Apple comienza a bloquear a los usuarios de Mac M1 para que no carguen aplicaciones de iPhone y iPad de forma lateral

apple-mac-habitacion

Actualización del 19 de enero de 2021: Apple ha revertido este cambio del lado del servidor y, una vez más, es posible cargar de forma lateral aplicaciones de iPhone y iPad no compatibles en una Mac M1. No esperamos que esto dure mucho, así que si hay alguna aplicación de iPhone o iPad que desees en tu Mac, descárgala lo antes posible.


A principios de esta semana, 9to5Mac informó que Apple pronto comenzaría a bloquear a los usuarios para que no carguen aplicaciones de iPhone y iPad en sus Mac M1. Ahora, Apple ha cambiado oficialmente el interruptor del lado del servidor para implementar este cambio.

Esto significa que ya no es posible usar una aplicación para cargar aplicaciones no compatibles desde tu iPhone o iPad a tu Mac M1.

Como actualización, Apple Silicon Macs permite a los usuarios ejecutar aplicaciones iOS y iPad en tu Mac, pero los desarrolladores pueden optar por no permitir que sus aplicaciones se instalen en Mac. 

Este es el camino que han tomado muchos desarrolladores, haciendo el cambio necesario en App Store Connect para eliminar su aplicación de la Mac App Store.

Pero dicho esto, hasta hoy, puedes instalar manualmente aplicaciones iOS como Netflix, Instagram y Facebook en una Mac M1 usando tus respectivos archivos IPA descargados con una ID de Apple válida. Mucha gente estaba usando herramientas como iMazing para completar este proceso.

9to5Mac ha confirmado que, a partir de hoy, esto ya no es posible a menos que la aplicación esté disponible en la Mac App Store. Apple ha activado el interruptor del lado del servidor necesario para bloquear la instalación de aplicaciones de iPhone y iPad en Apple Silicon Macs.

El cambio se aplica a las Mac M1 que ejecutan macOS Big Sur 11.1, así como a la versión beta pública o para desarrolladores de macOS Big Sur 11.2. La única diferencia es que los usuarios que ejecutan macOS Big Sur 11.2 beta verán un mensaje de error más específico.

Este es el error que se verá cuando se intente instalar una aplicación de iPhone o iPad no compatible en tu Mac M1 con macOS 11.2 beta:

bloque-apple-mac

Si intentas cargar una aplicación de iPhone o iPad en una Mac M1 con macOS 11.1 Big Sur, verás un error que indica que la instalación de la aplicación no se realizó correctamente y que «vuelve a intentarlo más tarde».

Si ya cargasté una aplicación desde su iPhone o iPad a tu M1 Mac, aún se ejecutará correctamente. Este cambio solo afecta a las instalaciones de nuevas aplicaciones. Además, si ya habías descargado un archivo .IPA, aún puede instalarlo.

El cambio en sí se realizó en el sistema de la App Store que entrega el archivo .IPA real y todo es parte de las API de Apple que administran las protecciones DRM (Gestión de derechos digitales) del sistema operativo. Debido a esto, es poco probable que se presente una solución en el futuro.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *